Kontaktujte nás: +420 603 196 637 (+420 603 1 ZONER) | djcechi@gmail.com

Magazín o bezpečnosti

Magazín o SSL certifikátech a certifikačních autoritách pro Vás píší odbornící z SSLmarketu.

Blíží se konec podpory TLS 1.0 a 1.1

(12. 2. 2019) Google díky svému prohlížeči Chrome začal tlačit na konec podpory starších TLS protokolů verze 1.0 a 1.1. Není to však jen Google, který o konec těchto protokolů usiluje - o konec TLS 1.0 a 1.1 usiluje též Apple, Microsoft, Mozilla a velcí poskytovatelé cloudových služeb. Co to znamená pro návštěvníky webových stránek a majitele serverů se dozvíte v tomto článku.

Co znamená konec podpory a kdy nastane

Konec podpory v nejpoužívanějším prohlížeči nastane v roce 2020 s verzí Chrome 81; poté bude prohlížeč používat protokol TLS 1.2 a 1.3. Starší z těchto dvou se používá již 10 let a nejnovější verze TLS 1.3 se rozšiřuje na servery a stává se již standardní součástí jejich vybavení.

Ukončení podpory je v případě Chrome postupné. Zatím bude prohlížeč varovat na nepodporovanou verzi protokolu hláškou v konzoli (dostupná přes F12), pak zřejmě viditelnější formou a nakonec ho Chrome 81 přestane úplně podporovat.

Ostatní výrobci SW a poskytovatelé služeb budou ukončovat podporu postupně - Microsoft u Office 365 21. října a Cloudflare 4. října 2019. Apple a Mozilla vypnou podporu protokolů v březnu 2020.

Příčiny ukončení podpory TLS 1.0 a 1.1

Čtenářům našeho magazínu jsou důvodu ukončení podpory starých protokolů jistě zřejmé - vzhledem k jejich věku a počtu jejich zranitelností už nejsou bezpečné a není vhodné je používat. Starší TLS 1.0 trpí zejména známými zranitelnostmi BEAST a POODLE; novější TLS 1.1 sice těmito zranitelnosti netrpí, ale úroveň zabezpečení stále není dostatečná. Tento "mezistupeň" se navíc v praxi příliš nepoužívá a není důvod ho nevypnout spolu s TLS 1.0; oba protokoly už na webu skoro nikdo nepoužívá a plně je nahrazuje TLS 1.2 (viz dále) a nově standardizovaný protokol TLS 1.3.

Kompatibilita software aneb proč se nemohu dostat na ten web?

Ukončení podpory zastaralých protokolů (v obecném smyslu) má dopad zejména na kompatibilitu starých zařízení. Protokol TLS 1.0 je poměrně starý - vznikl v roce 1999. Pokud na něj nějaký operační systém spoléhá, tak se jedná o velice starý a nepodporovaný sytém.

Největší problém může konec podpory TLS 1.0 a 1.1 činit starším verzím smartphonů s Androidem. Tento systém podporuje TLS 1.2 od verze 4.4.2 a starší verze tento protokol neumí; jsou však stále používány. V naší interní statistice jsou zastoupeny méně než 3 % návštěv a nemusíte se tedy obávat velké ztráty návštěvníků.

Kombinace operačních systému a prohlížečů, které nejsou kompatibilní (podle SSLlabs.com):

  • Android 4.3 a starší
  • IE 6 / XP
  • IE 7 / Vista
  • IE 8-10 / Win 7
  • IE 10 / Windows Phone 8.0
  • OpenSSL 0.9.8y
  • Safari 5.1.9 / OS X 10.6.8
  • Safari 6.0.4 / OS X 10.8.4

Jak vidíte, jedná se o velice zastaralé operační systémy. Jejich podpora už dávno skončila (u Windows Phone skončil i samotný vývoj). Jediný problém může nastat u Windows 7, které mají stále asi 26% podíl na trhu - návštěvník s Windows 7 by mohl mít problém s integrovaným Internet Explorerem verze 8-10, protože v nich je defaultně vypnuté TLS 1.2. Tito uživatelé systému by však měli mít k dispozici už Internet Explorer 11, který problémem s nekompatibilitou netrpí; případně změnou nastavení TLS 1.2 povolí.

Vypnutí TLS 1.0 a 1.1 se neobávejte, máme TLS 1.2 a 1.3

Po ukončení podpory obou zmíněných verzí TLS se budou servery spoléhat hlavně na verzi TLS 1.2. V úvodu jsem zmínil, že tato verze se již používá dlouho; pro bližší představu přidávám souhrn prohlížečů a jejich verzí podporujících TLS 1.2 (zdroj):

  • Internet Explorer - ve verzích 8-10 možno manuálně zapnout; defaultně zapnuto až od verze 11
  • Chrome-  od verze 30 (rok 2013)
  • Firefox - od verze 27 defaultně zapnuto (únor 2014)
  • Safari - od verze 7 (OS X 10.9 z roku 2013)

Současně nejpoužívanější verze TLS 1.2 se tedy používá už šestý rok. Zdali ji umí i váš prohlížeč si můžete vyzkoušet v testu SSL/TLS Capabilities of Your Browser od SSLlabs. Google uvádí, že tyto dvě verze protokolů se v Chrome používají pouze u 0.5 % spojení a ostatní prohlížeče potvrzují nejvýše 1% využití mezi uživateli.

V současnosti moderní prohlížeče už podporují nástupce TLS 1.2; nejnovější protokol TLS 1.3 se už začíná rozšiřovat a připravujeme návod na jeho použití na linuxovém serveru. Zdali Váš prohlížeč podporuje TLS 1.3 si můžete vyzkoušet na četných testech, nejlépe na předchozím odkazu od SSLlabs. Pokud je výsledek testu negativní, tak s největší pravděpodobností není TLS 1.3 v prohlížeči zapnuté. Jak na to poradí například článek How to Enable TLS 1.3 in Chrome, Safari and Firefox?

Kromě vyšší úrovně zabezpečení si možná všimnete i rychlejší odezvy při načítání webových stránek; za to vděčíme lehce kontroverzí funkci 0-RTT Resumption, která urychluje obnovení předchozího spojení a nedochází k novému handshake mezi prohlížečem a serverem. V důsledku může ušetřit milisekundy při "domlouvání" bezpečné komunikace díky použití uložených informací z předchozí session (více o tomto tématu přehledně zde včetně pochybností o bezpečnosti).

Závěr

Vypnutí protokolu TLS 1.0 a 1.1 se nemusíte obávat. Pokud jste pouze uživatel internetu, tak změnu ani nepoznáte (pokud nemáte velice staré vybavení). Provozovatelé serverů se nemusí obávat protokoly na serveru vypnout. Sice mohou přijít o jednotky procent návštěvníků, ale zvýší bezpečnost ostatních. Nástupce těchto dvou protokolů TLS 1.2 je široce rozšířen a moderní prohlížeče už využívají nejnovější TLS 1.3.

Další čtení a informace

  1. Michal Špaček: Vypněte TLS 1.0 a 1.1 už dnes. Dostupné na Zdroják.cz.
  2. Modernizing Transport Securit.  Dostupné na Google Security Blog.
  3. Deprecating TLS 1.0 & 1.1. Dostupné na Blogu DigiCert.

Ing. Jindřich Zechmeister
Specialista pro bezpečnostní SSL certifikáty
Certifikovaný Symantec Sales Expert Plus 
e-mail: jindrich.zechmeister(at)zoner.cz